University of Cambridge Computer Laboratory - Some mail into Fastmail is bouncing – Incident details

Some mail into Fastmail is bouncing

Resolved
Operational
Started about 2 years agoLasted 8 days

Affected

Fastmail email

Operational from 9:59 AM to 5:06 PM

Third Party: Fastmail → Mail delivery

Operational from 9:59 AM to 5:06 PM

Updates
  • Resolved
    UTC
    Resolved

    We have not seen any reoccurrence of this issue since 2024-07-22 at 14:20, which coincides with when Fastmail fixed another problem, so we hypothesise that they fixed this one too by accident. However they are continuing to investigate.

  • Update
    UTC
    Update

    Fastmail has clarified that they have fixed only one of two issues that we reported, and it may be the case that mail continues to bounce with "bare <LF>" errors. We are in communication with Fastmail engineers to investigate the remaining problem, which appears to be a complex software bug. Nevertheless mail has not been bouncing for the past 21 hours so the problem may have been fixed by accident.

  • Monitoring
    UTC
    Monitoring

    Fastmail has now confirmed that they have implemented a fix for the problem.

  • Update
    UTC
    Update

    We have still not heard back from Fastmail, but mail seems to have stopped bouncing around 14:20 yesterday. We will continue to press Fastmail for an update and will continue to monitor the situation ourselves.

    If you are a Fastmail user and would like us to check our logs for any mail to you that bounced, please contact service-desk@cl.cam.ac.uk.

  • Investigating
    UTC
    Investigating

    We are aware that Fastmail are bouncing some mail to users of fm.cl.cam.ac.uk with an error message such as "Error: bare <LF> received". We will ask Fastmail to investigate.