University of Cambridge Computer Laboratory - Intermittent internet connectivity fault - UK-wide DDoS – Incident details

Intermittent internet connectivity fault - UK-wide DDoS

Resolved
Partial outage
Started 7 months agoLasted about 19 hours

Affected

Network

Partial outage from 3:43 PM to 10:39 AM

Updates
  • Resolved
    Resolved

    UIS has declared the DDoS-related disruption to be resolved, though they note that there may be some residual issues this morning, including delays to email delivery.

    We observe that some email was delayed for several hours overnight; Jisc's mitigation of the DDoS attack seems to have blocked some legitimate connections into and out of the University, particularly email-related ones.

  • Monitoring
    Monitoring

    Jisc have confirmed that the attacks are across multiple UK universities.

    We observe that Jisc are implementing strategies to reduce the impact of the attacks, and the network is becoming more usable, though performance is likely to be impaired and some things may not work.

  • Identified
    Update

    UIS has posted an update: "The University is currently experiencing a DDoS attack. CSIRT are liaising with JISC - we'll update when we know more."

  • Identified
    Identified

    We are aware of an issue affecting the University's connections to the internet. This appears to be a widespread fault outside our control, affecting several institutions.