Resolved
West Cambridge Data Centre: loss of power resilience

Started
October 31, 2023 at 6:15 PM
Status
Resolved after 32 minutes

Impact

Partial outage
Affected
Datacentres
WCDC
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    Power has been restored but we believe maintenance is ongoing.

  • Identified
    Identified

    One of the two power feeds to each of our racks in WCDC has suffered another unannounced outage. Services are currently unaffected as everything can operate from the remaining power feed, but should be considered at-risk.

    We believe this is planned remedial work, but received no warning of the impact.