University of Cambridge Computer Laboratory - Mailing lists rejecting email – Incident details

Mailing lists rejecting email

Resolved
Operational
Started 19 days agoLasted 5 days

Affected

Internal Services

Operational from 2:39 PM to 6:03 PM

Other Internal Services

Operational from 2:39 PM to 6:03 PM

Updates
  • Resolved
    Resolved

    We believe that Mimecast has unblocked us.

    There are some unrelated issues with some mailing lists still under investigation, not connected in any way (as far as we know) with the Mimecast problem; if you experience any more problems please contact service-desk@cst.cam.ac.uk.

  • Identified
    Identified

    We believe that UIS has successfully worked around this issue, and email sent to mailing lists from departmental addresses should now work.

    However, we now also believe that this was a symptom of a broader problem with email to one particular email anti-spam service provider, Mimecast. Email to other institutions which also use Mimecast may also be affected. We are working on getting this resolved.

    If you do encounter the issue, you may be able to get email through successfully by sending from an @cam.ac.uk address.

  • Update
    Update

    As a workaround, messages should get through if you send mail using Outlook from your @cam.ac.uk address to the relevant internal @lists.cam.ac.uk address for the mailing list; if you don't know what that address is for a particular list, contact service-desk@cst.cam.ac.uk.

  • Investigating
    Investigating

    We are aware that UIS's mailing list service is rejecting some email sent from Exchange Online to University mailing lists via cl.cam.ac.uk/cst.cam.ac.uk aliases. We have asked UIS to investigate.